Unfinished New Game +

If you are stuck in the Dunan Unification Wars; or wish for more details on the gameplay systems, this is the place.
ne__ya
Posts: 26
Joined: Wed Dec 07, 2016 8:47 am

Re: Unfinished New Game +

Postby ne__ya » Thu Dec 29, 2016 10:32 am

What a summary!

1) I thought it's about time that I took a closer look at Pyriel's script commands, and actually managed to work around the crash.
In file VJ24, this is the part where the Rune tells Riou to close his eye and it crashes:

Code: Select all

05 18 08 00 0D 49 0F 45 02 0B 02 02 B4 1E 02 00 65 09 0F 0D 05 00 00 00 31 26 FF FE FF

Open the rom in a binary editor, search for the above, take out "1E 02 00" (add "00 00 00" at the end to make up for the difference), and it works well. And no, these are no glimses of good ending that you see. You are taken back to the Unicorn Brigade Camp at the very beginning.
"0D 05 00 00 00 31 26" is the part that takes you to destination 00-00 at coordinate X,Y=31,26.
When you go through the Unicorn Brigade Camp event and jump down into the waterfall, you get like a second of the Intro and it crashes. The reason for the crash could be that my save isn't good (it's with 108 recruits). Since I don't have a non-108-recruits save state, I've been looking around instead.
Genkaku's Story event seemed to be a good example as the script goes back and forth between "destinations" (or files). And indeed, it uses "0D 50 AA MM ?? XX YY" to jump from one file to the next. Unfortunately, I couldn't find any "0D 05 09 17" in the whole rom that would take you back to the unknown tower. Also, as far as I could tell, there are no script command in file VJ24 that references any later text by the Rune (make your last save, etc).

I am not sure if this would mean newgame+ starts at the Unicorn Brigade Camp. If true, it would be kind of dull to make you walk through the same Unicorn Brigade Camp event twice in a row, so you'd probably get to skip it and start with the Intro, or at the river bank. The question would remain what would happen with Riou's Shield Rune, though.
On the other hand, this certainly does not rule out the Sindar Ruin theory, either, still a strong one with the two-headed snake and all.
Either way, from analysing the script commands, I am afraid that this event really may never have gotten further than this. Then again, I am certainly no expert, and it wouldn't be the first time I overlooked something.


2)Further down in VJ24, there is the script command that takes you back to Sajah for easy comparison to the above:

Code: Select all

06 18 08 00 15 49 0F 45 03 0B 04 02 78 0D 05 09 10 00 4E 1C FF FE FF

"0D 05 09 10 00 4E 1C" where 09-10 is Sajah, at coordinate X,Y= 4E,1C. Using the escape talisman cheat with these parameters confirms that it is exactly at the rock.
(changing the "45 03" to "45 02" takes you to black Sajah, by the way)
I couldn't quite reproduce how you appeared beyond the boundary. Maybe some coordinates from the cheat were left over?


3) I think I got the tower (yup, it's certainly not underground) finally figured out.
The correct summary should be as follows:

09-11: arrive at B1, maps B1-F5, orb stand F3
09-13: arrive at F6, maps F6-F10, orb stand F6
09-14: arrive at F1, maps F1-F5, orb stands F2 (upper), F4
09-15: arrive at F6, maps F6-F10, orb stand F9
09-16: arrive at F1, maps F1-F5, orb stand F2 (lower), F5
09-17: arrive at F6, maps F6-F10(alt), on to F11, orb stand F9

EDIT: 09-11 is connected to 09-13 which leads to 09-14 -> 09-15 -> 09-16 -> 09-17, all in a row.
The tower thus is 31 stories high, plus basement.
It didn't make sense that 09-11 and 09-13 would be sharing orb stands while others were scattered all over. Like this, there are 8 orb stands, just twice in the location of F9.
At the end of 09-11, 13, 14, 15, 16, there is always a boss fight, so it crashes because the boss is mostly undefined, but moving between destinations shouldn't be causing the crash.

The chest sprites were probably just prepared, but never got placed into the maps with contents.
walk-through-walls in Japanese version: no luck! a comparison of savestates in JA and EN would be required.
I agree the tower meant for a solo run - it's kind of fun bribing your way through it. lol

Omnigamer
Posts: 282
Joined: Wed Feb 13, 2013 11:48 am

Re: Unfinished New Game +

Postby Omnigamer » Thu Dec 29, 2016 11:50 am

I fully expected it would start all the way from the beginning again; too many inconsistencies to smooth over from a Sindar refresh. Plenty of things would get more complicated to fill in, like a) what level are your characters? b) did you skip Nanami? c) What's in your inventory? This also allows for things such as trying the 108 Battles and Rowd fights, or getting a different vase. The Double Head statue is just a silly cameo, imo.

Could you check your status during the Unicorn Brigade Camp revisit? What I'm most curious about is whether they preserve your inventory and potentially level/equipment when they restart you. If so, that would be the simplest way to implement it, ie, you carry over only exactly what you have. Assuming they don't have some script in the story to completely empty Barbara's storehouse and similar things, you may keep everything in them as well.

User avatar
Pyriel
Webmaster
Posts: 926
Joined: Wed Aug 18, 2004 1:20 pm

Re: Unfinished New Game +

Postby Pyriel » Thu Dec 29, 2016 1:15 pm

The code doesn't say, "dungeon," that I know of. I just called it that so I'd have something to call it. And 09-12 isn't skipped, it's just not a related module. I don't recall if it's actually used in-game, or if it's somehow redundant. I'm about half certain it's not redundant, though. I recall it led somewhere distinct from other values.

I think 0x1E is for executing script extensions built into the module. Possibly removing that command prevents the script from clearing data properly. If you're dumped on the first screen with all the flags set, you can surely count on something blowing up eventually. Did you notice anything odd? That first script with Jowy could be loaded without the need for any triggers, but after that, things could get interesting. I'm sort of expecting that if you told Jowy you wanted to look around instead of sleeping right away, you'd leave the tent to find you were already under attack.

ne__ya
Posts: 26
Joined: Wed Dec 07, 2016 8:47 am

Re: Unfinished New Game +

Postby ne__ya » Fri Dec 30, 2016 6:16 am

I went looking for the EN address of the script commands, so anyone can try it playing the game. The script starts around $113E80 (EDIT: in JA version it's pretty close by, around $113EE0). In case you only get a black screen, it may help to erase "45 02" also. Just always remember to add "00" after the first "FF FE FF" to make up for the difference.
(the script command for Sajah is around $113EC0, and erasing "45 03" will take you to normal Sajah. "45 xx" might be some kind of mask)
Here's a try at having it as "cheat code". You should turn it off after things are overwritten, before talking to the Rune.
Please correct if it doesn't work:

Code: Select all

erasing "1E 02 00" (EDIT: +$60 for JA version)
80113E90 0965
80113E92 0D0F
80113E94 0005
80113E96 0000
80113E98 2631
80113E9A FEFF
80113E9C 00FF
80113E9E 0000

erasing "45 02" and "1E 02 00"
80113E8A 020B
80113E8C B402
80113E8E 0965
80113E90 0D0F
80113E92 0005
80113E94 0000
80113E96 2631
80113E98 FEFF
80113E9A 00FF
80113E9C 0000
80113E9E 0000 

I was hoping to get same results as in JA version, but my EN save state from early in the game only showed the Unicorn Brigade Camp *after* the attack with no more event to process.
With the JA version, where I tried the before-Beast-Rune and before-ending save (both with 108 recruits), however, all events flow normally. You can go out of the tent and everything's OK. I think it's more a matter of the save state than language version. Maybe at some point, these flags get cleared.

Yesterday I mentioned that I could not find any "0D 05 09 17" within the rom. But I realize that there must be other ways of moving between files, because otherwise I'd at least have found one at 09-16 to move on to 09-17.


Yes, it's true that some decisions early in the game would not be accessible if newgame+ didn't start at the very beginning. But I'm still very much for the Sindar Ruin theory.
a) I guess that might be a problem, but Nanami could easily be set at the level in case she joins at Muse. Jowy could be at the level when he leaves at Muse, or set to match Nanami's level.
b) Nanami isn't a problem since the Sindar Ruin event happens after she joins at Muse.
c) Inventory is indeed an issue. But, if the newgame+ starts at the very beginning, Riou must lose his Shield Rune so he can get it again. In that case, I kind of doubt you get to take anything along with you at all.
To come think of it, the "Blinking Mirror" would certainly be taken away for a newgame+, so you'd probably only get to carry over what is equipped, if anything at all.
And most of all, it would be such a waste of the story behind it, its ideal position within the game... Murayama being a story teller, I'd like to think the newgame+ wouldn't be just a functionality, but has some story to it.
But well, yeah, it's no more than a theory anyway.

Jowy that joins at the Unicorn Brigade Camp in the flashback (or "flashforward" I should say) is at the same level when he left at Muse. This may be the consequence of having deleted 0x1E. My own status and everyone else's is the same. At first I hadn't gone solo into the unknown tower (that was a save before Beast Rune), and I had to pick a member to leave when Jowy joins. A solo run didn't prevent the crash at the waterfall.

JiN88
Posts: 14
Joined: Tue Dec 20, 2016 11:40 pm

Re: Unfinished New Game +

Postby JiN88 » Fri Dec 30, 2016 7:08 am

I just realized what I'm doing is essentially trial and error while ne__ya is doing the important data mining. Lol. Which to say isn't so bad since you need someone to confirm the things you found anyway as well a fresh set of eyes. Also some things might be better to see how the developer intended it... and more fun.

Omnigamer, that would be great if we can have the save files.

Pyriel, 09-12 leads to the place where Jowy stabbed the Jillia doll to rile up the soldiers. Doesn't seems significant other than just graphical assets for the event. Nothing to interact either.

ne__ya, will try the codes but I have some concerns

Anyway I found some more interesting stuff. It all started when I lagged the game a bit and noticed some graphical glitches and realized I could take advantage of it, so, I set interpreter on the emulator to slow (This allow some of the code for event or graphics to load slower than the other counterparts i.e music first before the event/load place, much like how the game works). It works on the same principle to see if you can glitch to see through stuff.

Is there any way to turn of the game graphics and assets for a while? Like removing the walls and floors to see the background so there might be more hidden stuff (Especially in the unknown tower). I used to do it for some Gameboy games on an emulator to find secrets .

Also, is there a way to disable boss encounters? will elaborate at the dungeon part.

1) The Rune

I managed to get past the Rune crash and got through the music. Setting the interpreter to slow allows the music to load perfectly while the Event fails to load (no crash so you can listen to the music fully looped and is softblocked):
https://www.youtube.com/watch?v=fhG-nFRB794
This is the one.
No idea WHERE but only the music is a clue. Anyone want to volunteer their New Years listing them out?

Also I realized that at the RUNE, picking going back to SAJAH flashes the screen to white while the other darkened the screen. I think there's a significant but I can't remember in the game what differences were there. (like saving darkened the screen (it doesnt) or loading to an area. Something like that)

Now this is the weird part.
The sequence of event should be The Rune do the talking, screen blackened, load and play that music, play the event and so on (Much like any other normal event if you notice: The music always plays first before loading the rest when you play normally)
The one that ne__ya did could just mean you teleport back to the beginning and no relation to the rune. *Not much knowledge on binary data so could be wrong*
My suspicions arose when the music IS NOT in accordance to the Unicorn Brigade Camp.The earliest usage is after during the attack and the encounter at the waterfall with prince Luca (I checked).

So either there's an event between the Rune and Unicorn Brigade Camp or something else. Most likely never implemented (T.T)

And yeah, wouldn't make much sense if you teleport to play back the beginning.

I doubt there's a any new Ending at all. The whole RUNE could just mean you play the game again at some point (with previous strength) and the endings would be the usual (bad ending with the cabin, kill jowy for the rune, don't kill jowy and be happy with Nanami, ignore jowy and become leader)

2) White Sajah

Using the same principle above I was able to glitch the graphic for a minuscule of a second to see through the white screen. And you're right it does teleport you (slightly) below the rock. The rock did not change.
Nothing much changed as far as I can tell (people were still the same and the birds are still alive and not dinner yet).
Since the white screen is most likely a graphical overlay issue, I think some simple coding could get rid of it.


White Sajah secrets all seems revealed unless something significant appears in the code. Maybe like bring the bad ending (no 108 stars) or some event.


3)The dungeon/tower

ne__ya, you're right. The tower does have bosses on floors linked to another and they do not appear to be merely placeholders and I think I figured out the bosses and most of the bestiary. I can say for sure for the first 2 bosses but not the rest:
using download/file.php?id=253 . All bosses appears at the stairs on the last floor to the next.
3006AA3F 00AA
3006AA41 00MM

-For 09-11: arrive at B1, from B1(to Sajah) up to F10(crash)
The boss is (By testing) the Poison Moth (Not the caterpillar).
Most ,I think all, the enemies encountered are Hollyboy, FurFur,Cutrabbit,

One weird thing that did happen (In The JPG) was as the battle begins, even before the first battle menu, just the music and the moth appear , it happened: The Moth got hit (receive damage animation) and died and I won.

The Poison moth only appears in the JPG version and crash in the ENG version at the same stairs but the bestiary seems the same. This means just some coding differences in the different versions to get the boss out.


-For 09-13: arrive at B1, maps B1-F5.
The boss is (By testing) the Sewer Rat
Most,I think all, the enemies encountered are Tiger (gold colour), Tantan RinRin TenTen, Samurai

Boss is fully functional.
Boss only appear in the ENG Version and crash in the JPG version (It straight up crashes the game) but the monster encounters seems the same.


-09-14: arrive at F1, maps F1-F5
The Boss ????. Either crashes the game or set it to a loop on both ENG and JPG.
Most (I think all) the enemies encountered are IronMoon, FishEye, CopperSun.

Not definite but:
This would mean the encounters are from Muse area.
So the boss (Given the previous bosses were big sizes) could be Golden Wolf


-09-15: arrive at F6, maps F6-F10

The Boss ????. Either crashes the game or set it to a loop on both ENG and JPG.
Most (I think all) the enemies encountered are zombie, Neclordia, Unicombie, Skeleton

Not definite but:
This would mean the encounters are from Tinto area or generally undead.
So the boss (Given the previous bosses were big sizes) could be Stone Golem or Abomination (More likely since it correspond to the theme)


-09-16: arrive at F1, maps F1-F5
The Boss ????. Either crashes the game or set it to a loop on both ENG and JPG.
Most (I think all) the enemies encountered are PinkBird, Phantom,

Not definite but:
This would mean the encounters are from Rockave area.
So the boss could be Gorudo (Could be wrong but he's the only one there)


-09-17: arrive at F6

The Boss ????. Either crashes the game or set it to a loop on both ENG and JPG.
Most (I think all) the enemies encountered are Magus, Chimera, Bronzem (Not the others due to different colours)

Not definite but:
This would mean the encounters are from L'Renouille Castle
So the boss (Given the previous bosses were big sizes) could be the Rune Beast or none as its at the gate already and there were no encounters.

Edit: Realized 09-17 doesnt have a boss encounter. added remark there might be none.

PS: If you're able to cancel the boss encounters the stairs should work and you can explore the dungeon uninterrupted. This is evident when I go down one floor down to meet a looped boss (This shows stairs works as what ne__ya said)

With this data, I think I can assume you fight the Beast Rune here since all of them are mini bosses corresponding to their areas more or less (their difficulties and theme are a bit of a mess but could be planning error)
Now, if we assume its true you fight the Beast Rune, then it would mean you're fighting the Rune beast, AGAIN--solo.
So that means you're suppose to visit the tower the AFTER the Beast Rune in L'Renouille Castle. Since, you know, if you meet the beast rune before the L'Renouille Castle it would seems weird. Soloing it would make it so much harder. Or could be some variant (Like just the orb for example)


Next step: get NO 108 STARS and see how it goes.
Last edited by JiN88 on Fri Dec 30, 2016 10:10 pm, edited 1 time in total.

Omnigamer
Posts: 282
Joined: Wed Feb 13, 2013 11:48 am

Re: Unfinished New Game +

Postby Omnigamer » Fri Dec 30, 2016 12:42 pm

I will see about finding my JP mem card tonight. I have an abundance of save states for the US version, but I'll need to make sure they're compatible with the latest release of BizHawk. Otherwise, I can absolutely make some .bins of the memory cards.

I still don't see much logic behind restarting at Sindar as opposed to the Camp. It just seems to make things harder to plan for with the only benefit being skipping a few early-story elements. Since the warping left behind in the code takes you back to the Camp, I don't see how you could expect it to be anything else. The benefit would come from whatever they let you restart with, be it items, levels, equipment, etc, and gives a point to all of those epilogue-only items by extension.

User avatar
Pyriel
Webmaster
Posts: 926
Joined: Wed Aug 18, 2004 1:20 pm

Re: Unfinished New Game +

Postby Pyriel » Fri Dec 30, 2016 8:08 pm

The most common method I've seen of loading modules and transferring the player to them is to load ahead of time with 0x1F and then transfer the player later with 0x20.

Code: Select all

0x1F         Area related.  Loads an area file.               0x1F {data 1} {data 2} {data 3}
         data 1 - memory region 0, 8010DC50; 1, 8015DC50; 2, world map region.
         data 2 - Area #
         data 3 - File #
0x20         ??                  0x20 {switch} variable number of arguments...needs evaluation.
         moves the player to a location  on a map managed by a previously loaded module.
         Data 2 is often the module's memory region and data 3 and 4 are the X and Y positions.


I searched for this ages ago, when I was trying to see if there was a way to restore the entrance, and didn't find anything except a few transfers between areas within the dungeon. It could still be in there. I'd never seen the 0xD command actually used before the last couple of weeks, so there could still be other ways. Although, I doubt there's much more. I can't see why they'd need 5 different commands for that, but it's seems at least a little likely that the conditional/trigger scripts might have a way to load a module.
Last edited by Pyriel on Fri Dec 30, 2016 8:10 pm, edited 1 time in total.

JiN88
Posts: 14
Joined: Tue Dec 20, 2016 11:40 pm

Re: Unfinished New Game +

Postby JiN88 » Fri Dec 30, 2016 8:10 pm

Omg. I tried using ne__ya new codes for a while. It works and I think I found something significant. I crossed check with resetting the game and playing the beginning to confirm it. I might need to recheck again. Was too excited and needed to post it first.

Normal text means after the Rune warp, Bold and underline for comparing resetting the game

My try: NO 108 STAR (I quickly played through using a previous save file), after beast rune, ENG Ver., Alone. There was no crash at the intro scene though (maybe ne__ya Rom version was different?)


Did everything and the Rune warped me back to the beginning.

Firstly, a garbled text appears at the top right telling you where you are. In the reset, it wasn't there and no text box even appears.

Went through everything normally until after Jowy asks you if you want to walk around. I did and quickly checked inventory. RIOU still has everything before I warped at the Rune while Jowy still has his stuff before his permanent departure, I think, as I was using a different save state and can't remember (The first time. With his rune but no hungry fiend and at lvl 19)

Quickly went back to sleep cuz wanted to see it through quickly .

Woke up by the attack. There were some changes: One extra line calling out your name and cancelling another I think. The reset just calls everyone they were under attack.

Jowy woke up talk to you and garbled a text (One line ONLY) appears. The reset part just have Jowy say something about "What about the peace treaty".

Played normally going straight to the mountain, meet Luca, fight the guards, jump into river (pretty much normal here and I tried to keep consistent decisions)


And the intro scene stands out. (I can't really tell whether its the Rune warp issue or emulator issue but the graphics did glitch a bit ):
-The staff credits were missed out or delayed, as in they appear a bit later in a different scene than their suppose to. Like the reset have the character design name at scene 1 while the Rune warp have it at about scene 3
- A new scene where Riou stands at the tree looking over the mountains IN COLOUR, ALONE :D . The normal reset have Riou and Jowy at the tree looking out the mountains in NO COLOUR. This, I think is a significant difference I I checked multiple time just to make sure. I can't really remember if you ever see the scene before in normal playthrough.

- Some graphical issue with the part where Riou and Jowy walked past the people as soldiers but some of the soldiers did not move.

Edit: previously thought the creator name only appeared in Rune Reset instead of the game reset. Checked and the creator name do appear at the game rest

After the intro scene and jumped into the river it was soft blocked. The reset have Viktor waking Riou up at the Riverbed.

I'll recheck with a fresh mind and probably try with the JPG version.

I did do a quick run with A 108 STARS, After the beast rune, ENG vers ALONE and got the same results I think.

So either ne__ya code fix merely teleport you back or there was really some changes.

Also, regarding your items being a nuisance (blinking rune etc.), it could all be remedied if the capture by Viktor strip you of all that.
Not sure on the rest.

Will try JPG version maybe.

Is there anything anyone wants me to try? Limited to the first area before the jump though.

Happy New Year.

Edit: Clarity
Last edited by JiN88 on Sat Dec 31, 2016 1:08 am, edited 1 time in total.

User avatar
Pyriel
Webmaster
Posts: 926
Joined: Wed Aug 18, 2004 1:20 pm

Re: Unfinished New Game +

Postby Pyriel » Fri Dec 30, 2016 8:50 pm

Looking around a bit, VJ24 and VA01 load at the same address. I wonder if 0xD isn't deprecated in the engine. Either it's an escape route for when pre-caching isn't possible, or it was the original solution before they decided to round-robin the modules about at several different locations in memory. If it's deprecated, that could be why some of the results you're getting seem off. If it's looking for setup data or code in locations that have been overwritten, the contents of VA01 might be getting stepped on before the scripts run.

I don't recall VA01 having any copies, nor do I remember seeing slightly modified copies of the same scripts in there.

Edit: Well, several of the other files for this dungeon are set to load at other addresses. It certainly looks like they had at least planned on using the 300KB regions of memory for different modules when this part of the game was developed. That doesn't mean they didn't discover a problem with transferring control immediately to a module that would overlay the one currently in use, but it definitely tilts the scale toward "no-pre-caching escape hatch" in my mind.

One of these days I'm going to have to bite the bullet and just play the game with a bunch of breakpoints on so I can work out the rest of the details of the scripting engine.

Omnigamer
Posts: 282
Joined: Wed Feb 13, 2013 11:48 am

Re: Unfinished New Game +

Postby Omnigamer » Sat Dec 31, 2016 10:54 am

Any chance you can screenshot a picture of the new Mountain scene with Riou? I'm curious about what it looks like, but also hunting down where the image is located.

JiN88
Posts: 14
Joined: Tue Dec 20, 2016 11:40 pm

Re: Unfinished New Game +

Postby JiN88 » Sat Dec 31, 2016 7:56 pm

Prerequisite:
N0 108. After Rune beast. Alone (no Mcdohl at the RUNE). Talk and decline offer to become leader in the banquet (I feel there might be some significant in decision if the development process wanted you to feel guilty before the Unknown tower)
http://coolrom.com/roms/psx/39634/Suikoden_II.php version (No idea which version this is but I think there is some significant in different version as far as my testing goes).

All cross checked by restarting the game.

The different version's I haven't really fully tried it yet as there seems to be some consistent results but can't get through ne__ya codes

https://www.youtube.com/watch?v=vw4oJHY ... vrLsMJl7bM for reference.

Using ne__ya codes to wrap from the RUNE:

PSOGL2_001.jpg


The first is the weird gibberish. I think it might be 千ユウトン扡 in the Japanese version. No idea what it means. You can use the talisman wrap in the JPG version with

3006AA3F 00AA
3006AA41 00MM
8006AA4E 0020 <- X-Pos
8006AA50 0020 <- Y-Pos

The same code Pyriel gave by using AA and MM to 00 and 00. It gave off the exact same thing as restarting the game but with sticking to your previous items and party and crashes the game later. The Rune warp gets you further.

Also using it with the JPG version seems to wrap directly DURING the ATTACK. So there might be some significant it that code.

PSOGL2_002.jpg

PSOGL2_003.jpg
You do not have the required permissions to view the files attached to this post.
Last edited by JiN88 on Sat Dec 31, 2016 8:17 pm, edited 1 time in total.

JiN88
Posts: 14
Joined: Tue Dec 20, 2016 11:40 pm

Re: Unfinished New Game +

Postby JiN88 » Sat Dec 31, 2016 7:58 pm

PSOGL2_004.jpg

PSOGL2_004_1_.jpg


As you can see The levels and Runes are there. Riou is exactly as after the beast rune and Jowy, I think its as before the departure at Muse (I think that was the city name. Also I can't really tell what his level was as I'm using a save state)

All items and special items remain the same after the Rune beast.

I tried briefly WITH 108 Stars after the beast rune. The same thing as well: having Riou at around Lvl 60 (after the beast rune) with Rune Forgiver sign BUT JOWY level around 20 (about the time he left from Muse) WITH Rune hungry fiend . I think its because the save file used cheat for it so can't really tell.


PSOGL2_007.jpg


Here's an interesting part. The Soldier should be shouting "Surprise attack!!!" and then no more. This text box appear after it with the hero name and nothing more.
You do not have the required permissions to view the files attached to this post.

JiN88
Posts: 14
Joined: Tue Dec 20, 2016 11:40 pm

Re: Unfinished New Game +

Postby JiN88 » Sat Dec 31, 2016 7:59 pm

PSOGL2_008.jpg



And this part only one line appeared and no more. The restart have Jowy with 2 text box saying something about the peace treaty and need to escape. No idea on what is it.

All other (outside, before and after) seems the same up to the waterfall. You can use the runes normally.
You do not have the required permissions to view the files attached to this post.

JiN88
Posts: 14
Joined: Tue Dec 20, 2016 11:40 pm

Re: Unfinished New Game +

Postby JiN88 » Sat Dec 31, 2016 8:01 pm

Now for the intro...all of them plays normally (no colour. Not gonna waste 108 battles for the colour to test...yet....maybe) with music but with some minor changes with the staff roll.
I can't tell if its either emulator problem or the RUNE warp problem as it did appears to be glitchy.
https://www.youtube.com/watch?v=e842SCjE9y4 for reference.

PSOGL2_009.jpg


The game restart should have "Character design Fumi Ishikawa" but the Rune Wrap doesn't



PSOGL2_010.jpg

The game restart should have "Monster design Hidehiko Kouyama" but the Rune Wrap doesn't.

:D :D :D :D :D :D :D :D
PSOGL2_012.jpg


The biggest difference!!. In the game restart there should have "Object design Jun Saitou" and Riou and Jowy at the tree with no Colour. The Rune Wrap have Riou STANDING, ALONE, with COLOUR looking out and its normal animated as the other. Oh and the Rune wrap has "Character design" and no more.
I can't recall if there's any part like this in normal playthrough.
You do not have the required permissions to view the files attached to this post.
Last edited by JiN88 on Sat Dec 31, 2016 8:11 pm, edited 2 times in total.

JiN88
Posts: 14
Joined: Tue Dec 20, 2016 11:40 pm

Re: Unfinished New Game +

Postby JiN88 » Sat Dec 31, 2016 8:07 pm

PSOGL2_013.jpg

Same as before. Rune wrap no staff credit while the other has.

PSOGL2_014.jpg

I'll add this but it might be insignificant. The restart and the Rune Wrap were identical even the staff credit "Main program Akiyoshi Oota" but The Rune wrap's staff credit was quick to disappear.



PSOGL2_016.jpg


The last one. Rune wrap has no staff credit and the soldiers, apart from Riou and Jowy marching normally, remain stationary (they just walk through them while nanami waves). Could be emulator problem but I restarted the game and seems fine.


That's it. Even the "Writer.Creator yoshitaka murayama" credit didn't appear for the Rune wrap and appears to be softblocked after the stationary soldiers part and screen blackened. The music did play fine in a loop. Occasionally did glitch (more like a flash) through the black screen for a sec, seeing the first scene without the trio.

Might do a video for better explanation.

Don;t really know what else to test though. I can't seem to get the Rune wrap in JPG version to work. I kept reading from the internet that the best version to try might be PAL version but I can't find any as well as its save files.

Any luck with cheatcode to disable boss encounters? I want to explore the tower more.

I think, maybe, the RUNE Warp has an extra event (as evident when I got through the music and it doesn't correspond to the Unicorn Brigade camp beginning) before the the Unicorn Brigade camp along with those minor changes with evidence.
You do not have the required permissions to view the files attached to this post.


Return to “Suikoden II”

Who is online

Users browsing this forum: No registered users and 5 guests